<< return to Pixycam.com

Firmware 3.0.9? Weird USB Issues


#1

I just received my pixy camera but am having weird issues.

I can connect it to my arduino and it seems to react to objects that I teach it but I can not for the life of me get it to work with pixymon.

I have the latest version installed and the pixycam shows up in device manager normally.

On my one W10 Desktop it keeps going

Pixy detected.
error: Unable to connect to device.

over and over

When I connect it in DFU mode it sometimes says programming state detected but never gets past that.

On my W10 laptop it says:

Pixy detected.
error: This Pixy’s firmware version (3.0.9) is not compatible with this PixyMon version (2.0.9).

Over and over.

Same deal with the DFU, driver installs fine but Pixymon can’t seem to upload a new firmware.

As far as I can tell there is no such thing as firmware version 3.0.9 so something somewhere is messed up.

Did I get a defective model? It seems to work with my arduino fine. I’ve tried multiple USB cables and ports. Not sure what is going on.


#2

So I figured out the problem.

I just googled Pixymon and opened the first result which was from cmucam.org

I guess that version was for the original Pixycam, not the V2 that I have.

I installed Pixymon v2 and it works on my laptop now.

Still doesn’t work on my desktop but at least I know that the camera isn’t defective.


#3

Hello Marcel,
Sorry for the problems and glad you got it working. Your feedback will result in some changes to cmucam.org (although I’m not sure what yet.)

thanks!

Edward


#4

I’ve gone ahead and edited all the cmucam.org wiki pages that show up in a Google search for “pixymon” with links to the new site…hope this helps!