<< return to Pixycam.com

In lego mode the lamp does not light on my pixy2

I try the lego test program of line tracking, the lamp box lit is good, but the lamp does not light up. When I am connected live to the pixy software the lamp works. What happens?

Please make sure you are using the latest LEGO firmware and the latest LEGO blocks
(what versions are you using?)



The block version is 2.0.9
The firmware version is V1.10E

The battery is at maximum.

It’s the same problem with version V1.09H

What version of firmware are you using with your Pixy2? If you bring up the About dialog on PixyMon with your Pixy2 plugged in, you will get the Pixy2’s firmware version.


Hello, i use

PixyMon v2 version 3.0.24
Pixy2 firmware version 3.0.14 LEGO build (queried)
Pixy2 hardware version 2.2.0 (queried)

You are saying that when you click the lamp box on the LEGO block and run the program, the lamp on Pixy2 does not illuminate?

What mode are you using – Color connected components, line tracking, or RGB?


That’s right. I use your test program in Line tracking mode.

I’m having trouble reproducing this issue. I downloaded and installed 1.10E firmware and still could not reproduce.

Can you describe what happens? Does the light turn on intermittantly when you run the program with the lamp set to true? Or does it not come on at all?

You say that the lamp works when you enable it through PixyMon?


Yes the lamp works perfectly via pixymon. In lego mode nothing happens, whether I activate the lamp in the block (true value) or not. No blinking, no nothing.

when I run the test program, I have the vector at 90 which does not move.The other values are 0 (barcode and intsctn). The arrow does not change direction.

If I unplug the pixy I have vector 0 on the screen.

Let’s take a step back. Does the ccc_test_program work with your Pixy2? Please follow the setup described on this page:



yes it works. I taught him a green ball and I can follow his shape on screen ev3. and if I activate the led lamps they work in this mode

You are saying that in Line tracking mode, the lamp does not work, but it seems to work in other modes. (correct?)


Does the lamp turn on at all? Is it intermittent in its operation in this mode?

Just to make sure, you are enabling the lamp by setting it to true (see below) while the program is stopped


and then rerunning the program by pressing the play button (see below)


Is this correct?


Yesterday it worked in line tracking mode but not today.
I did all the tests again:
Directly on Pixy, the lamp works.
In Lego it does not work on any mode today obviously following the method you indicate.

We have not been able to reproduce this issue. We can not fix it until we can see it on our end.

What version of your EV3 sofware are you using?


I use the education version

The version number please. Go to the Help menu and click on About LEGO… to get the version.


the version number is 1.4.2

I tried version 1.4.2 (the only version I could find was the Education version.) I’m sorry, but I was unable to reproduce the issue.

As a final thing to try – bring up PixyMon and restore the default parameters:


We’ll reach out to other users to see if they’ve experienced this issue. Perhaps we can get some more clues on how to reproduce. You are the only user (at this point) to report this.

Our apologies that we don’t currently have a fix. .