<< return to Pixycam.com

Pixycam2 wont connect via USB

I was testing the Pixycam and tried using a different interface than I2C(I believe I picked the first option) by changing it via configuration tab.
After I did that the camera doesnt open via PixyMon application and says “unable to connect to device”.
I’ve pulled up device manager to see if there is a issue with the driver and it doesnt seem like it does. I even tried to uninstall the PixyMon application including the driver via device manager and redownloading everything, still no luck .
Lastly I tried put the Pixy cam into firmware mode and uploaded the most updated firmware on the camera and it still is giving me issues.
The LED flashes pink and white twice when I plug in the camera via USB and then goes to a faint LED. I’ve tried holding down the button on top or pressing it 3 times, I dont know whats wrong with the camera.

Is there a way I can reset the settings manually?

After uploading the firmware, are you able to communicate with your Pixy via PixyMon?


No it still reads “unable to connect to device”

I’m guessing that something was damaged on your Pixy when hooking up through the I/O port. There is ESD protection on the IO port but no protection against reverse polarity.