<< return to Pixycam.com

PixyMon Cannot Connect Pixy2 under Linux


I have followed the installation guide in Installing PixyMon on Linux. My OS is Mint as it suggested.

The PixyMon is able to detect the Pixy, but it cannot connect.


I have tried the camera in Win10 and Arduino, it is working perfectly. I am sure it is not a camera problem.

I have also updated the firmware to the latest.

For your information, my version of the OS is:

Distributor ID: LinuxMint

Description: Linux Mint 19.1 Tessa

Release: 19.1

Codename: tessa

Please help me to get it working with Linux, because we are going to use it in the Linux ARM.

Have you tried running PixyMon with root permissions?

e.g. “sudo ./pixymon”


Yes. I started the program by the sudo command. The response is in my questions above.

Hmm, that’s pretty odd. Is it an Intel platform?

Also, do you have a Windows machine that you can try the Windows PixyMon release and see if it works with your Pixy2? This will help us determine if it has something to do with your Pixy2 as opposed to something on the Linux side.


As I have said in my question. The pixymon in the windows works great but not in the Linux.

My apologies for missing that. We aren’t sure what the problem might be. You might try other USB ports – perhaps USB 3.0 is causing problems? Do you have a non-blue colored USB port?

I’ll also ask around and see if we can get Mint 19.1 installed here, although that seems like a unlikely cause.


Hi Edge:
Thanks for your support.
Unfortunately, my laptop has two USB2.0 and the PixyMon works just fine when I connect the camera to those ports. I have also tried to read the data from I2C in the Linux ARM. It seems to work good.
I assume the problem is in the PixyMon for the Linux.

/Jianyuan Ma

I thought you couldn’t get Pixy2 to work with your Linux platform – you are saying it works with these ports? (or maybe I’m not understanding what you mean by “works”)


Sorry for the misunderstanding. I have Windows and Linux in my laptop. I can use the Pixy2 in my Windows through USB 2.0 ports, but not in the Linux.

I also have a Linux ARM develop board which is the one I am going to to use it together with the Pixy2. It does not work through the USB 2.0.

Someone is going to contact you via email.