<< return to Pixycam.com

Pixymon: response0x0

I connected my Pixy to an arduino. I tried running ccc_helloworld, yet I got:

error no response

in the serial port console. When I connect our Pixy to a laptop directly through USB, Pixymon’s console outputs the following:

runProg 0
response: 0 (0x0)

However, the video seems to work fine. The Pixy was also completely functional for a month. I have tried reflashing the firmware, using different Pixies, using different USB cables for power, and attempting to use different pixies with different computers. All of my pixies return response: 0 (0x0).
All the pixies were originally Lego Pixies, but we reflashed them with the general firmware

Are you using a Pixy1 or Pixy2?

If you are using the Pixy2 Arduino library with Pixy1, it will not work :frowning:


I am currently using a Pixy2.

Note, the “response: 0 (0x0)” printed on the PixyMon console means that there was no error when it switched programs, so there’s nothing to worry about there.

The “error no response” on the Arduino console is a different issue. Please refer to this troubleshooting guide:


Let me know what you find.