<< return to Pixycam.com

Pixyt_test and RGB_test from EV3 using Pixy2 not working

I followed the tutorials from https://medium.com/kidstronics/lego-meets-pixy-8f8ea7677114 and referred docs.pixycam.com as well. After running the ccc_test or RGB_test code, am not getting the respective results. It shows the following constant output regardless of the input from the Pixy2.

Pixy2 detects the saved Signature 1 color code but the data is not recieved to the LEGO.
I have tried changing the firmware version (old and latest) of Pixy2, tried with I2C and Lego I2C interface, tried using both 1.09H and 1.09E EV3 firmware and every other possible troubleshoots, however, I still couldn’t get the ccc_test and RGB_test code working.

This forum is the only hope left for me to find the solution.
PS: If i have missed out any important details, please do ask me.

The article at https://medium.com/kidstronics/lego-meets-pixy-8f8ea7677114 is for the Pixy1. If you’re using Pixy2, be sure to use the docs here:


An important question is the cabling – are you using the v2 LEGO cable that came with Pixy or are you using a cable that you made yourself?


Hi Edward,

Thank you for the response.

Yes, it is for Pixy1 but I dont see any changes for Pixy2 as well (It’s the same wiring for Pixy2). As said previously, I have gone through the Pixy2 instructions for Lego from the pixycam docs very well too.

The cable for the Pixy2 to Lego is made by myself but it was working fine. Apparently, I found out that issue was with the Pixy2 (A) module itself. I tried the same tutorial with another Pixy2 (B) and it worked perfectly fine.

The first Pixy2 (A) that I was working on had no isses with the UART mode. The issue was only with the I2C interface. I have mailed to the [email protected] for assistance but they couldn’t help me much on this issue.


The LEGO cable is different for Pixy1 and Pixy2. Hopefully you’re not using a version 1 cable.