<< return to Pixycam.com

Running ccc_hellow_world program on Raspberry pi pico outputs "error: no response"

When I run ccc_hello_world using raspberry pico, I get an error: no response on the serial port.
I added SPI pin setting to the first line of void setup to make the program apply to raspberry pi pico.
Does anyone know how to solve this problem?
Thank you in advance.
This text was created using a translation, sorry if it is wrong.

We don’t have Pico support yet (sorry). I have two thoughts:

  1. Have you tried switching TX and RX signals (also known as MOSI and MISO)? (This happens to me all the time!)
  2. Our Arduino SPI class makes this call:


MSBFIRST is common, but SPI_MODE3 could be a problem (?) for the Pico. It seems like it’s supported though. Are you using the latest Arduino-Pico core?


Sorry for the late reply.
After trying different ways to communicate with Pixy2, I added delay_microseconds(10) to the end of the loop and it works fine.

Nice work and that’s great news! Would you mind sharing your code?