<< return to Pixycam.com

Too light sensitive indoor

Hi there.

I’m now quite confident using my pixy2 camera, and managed to fullfill quite complexe tasks (grabbing a bear in the fridge remains my masterpiece :stuck_out_tongue: !).

Still, I’m from the begining confronted with the same issue : the camera is way too light sensitive in my opinion.

I have no issues teaching a color or CC outdoor or indoor at night.

But during the day I find just impossible to use the pixy2 indoor: colors differ way too much depending on wether a window is behind my robot or in front of it.

Are there any usefull tips in that regard ?

Thanks in advance.

Have you tried reducing the framerate?


If you reduce the “min frames per second” parameter, it will give Pixy2 more flexibility in low-light conditions. In general, it leads to better image quality and more detection accuracy.

Hope this helps!


I did play with it yes.
I goofed around with pretty much every setting at this point to be honest.
But my problem is rather an excess of light I guess.

The thing is that I have two huge french windows on my ground floor, so I can’t avoid direct sun lightning inside.
When moving accross a single room I can see the impact of it on the camera via pixymon : when facing a windows colors become very dark compare to when facing a wall.

I sometimes manage to bypass this by using several signature code for a single object. But managing false positive become a nightmare then, and depending on the weather or the moment of the day the result varies a lot.

Is it possible to save two different camera brightness ?

You can use the setCameraBrightness function:



I could try something with it maybe, but will still lose track of the object during the process though.

Do you think some sort of IR blocker film could help here?
I don’t know much about camera lens and light exposure…

IR blocking probably won’t help. Pixy’s lens has a IR block filter built-in.