<< return to Pixycam.com

UART Connection for Pixy and Arduino


#1

Dear Guys:

I am trying to connect the Pixy to Arduino Uno via UART. This is to free the SPI for an SD Card module so that I can create a talking robot. At first, I tried compiling the Pixy example “UART” onto an Uno but it does not compile due to “SERIAL1 error”. However, the compiling is successful for Arduino Mega so I used the Mega.

I used the Mega to connect to the Pixy using UART. I connected the I/O ports 1 (RX) and 4 (TX) of the Pixy to the pins 68 (RX) and 3 (TX) of the Mega, which I assigned as SoftwareSerial in the code respectively. Of course the Pixy’s RX is connected to the Mega’s TX and Pixy’s TX to Mega’s RX. The I/O port’s GND of the Pixy is also connected to the Mega’s GND.

Given the above, I cannot make it to work. There is no output on the Serial Monitor, it only shows “Starting …”. There seems to be no output from the Pixy to the Arduino.

Has anyone successfully implemented UART connection between Pixy and Arduino? Any help is appreciated.

Thanks Guys,
JC


#2

Hello,
The UART example won’t compile with the Uno because there isn’t a UART port available, only 1 for the console.

Usually, RX goes to TX and TX goes to RX. Have you tried to reverse the signals? Also make sure the baud rate is correct and you’ve set the “Data out port” to UART.

https://docs.pixycam.com/wiki/doku.php?id=wiki:v2:pixymon_index#interface-tab

Edward


#3

Thanks Edward!

All the baud rates match at 19200. The Mega, Pixy and the serial settings of the laptop. I have tried switching the rx tx as well but nothing is happening.

Am I missing some wiring or other software setting? Thanks


#4

Make sure you have grounds connected (in addition to rx and tx).

Are you using Pixy1 or Pixy2?

Pixy1 will only send data out the serial port when running in “default” mode. It will not send data in “cooked” mode.

Edward