<< return to Pixycam.com

Pixy Detected - error: Unable to connect to device.

I open Pixymon, plug in the device, the LED flashes twice, the servos try to move (when connected) & then in the software, I am getting a loop of:

“Pixy detected.
error: Unable to connect to device.
Pixy detected.
error: Unable to connect to device.”

My OS is Mac OS X 10.11.4

Hi Yao Li,

sorry to hear you are having trouble! Has Pixy ever worked on your system, or is this suddenly happening? Where and when did you order your Pixy?


My Pixy has not worked on my system. I order my Pixy from Amazon.com on March 19.

OK. Have you tried swapping USB cables? Are you aware of our troubleshooting guide here? http://cmucam.org/projects/cmucam5/wiki/I_get_the_message_"No_Pixy_devices_have_been_detected"_in_PixyMon

The main two things to check are driver incompatibility, and an inferior USB cable.

If that doesn’t solve the problem, let me know. You may have a defective device.


I tried swapping USB cable, and I can see Pixy CMUcam5 in the System Profiler. But I don’t see the LED cycles through the colors when I hold down the button. I reload the firmware successfully, but the problem isn’t solved.

Hmm, OK. Emailing you to set up a return.

I am having this same issue (the “detected but not connected” loop), but it was related to VMWare.

I posted the solution I found here : Solution for VMWare if Pixy is detected but cannot connect