<< return to Pixycam.com

Pixy detected. error: Unable to connect to device

Trying to use pixyMon with original Pixy and am getting the message
“Pixy detected.
error: Unable to connect to device.” in a continuous loop…
I have tried multiple usb cords as well as multiple computers all with the same result. I have even reinstalled the firmware countless times and tried older versions with no luck.
It seems it may be dead :’(
I have a project coming up soon that I really would like to use this on so any help in resolving the issue would be deeply appreciated!

Hi, sorry you’re having trouble! I’ll follow up with you via email.

I am having the same issue. Any help would be greatly appreciated!

Are you using Pixy1? If so please refer to this troubleshooting guide:


If you are using Pixy2, please refer to this troubleshooting guide:



I’m also having a similar problem, I really need help so that my project can be completed immediately, I really appreciate what help is given to me

I am having this same issue (the “detected but not connected” loop), but it was related to VMWare.

I posted the solution I found here : Solution for VMWare if Pixy is detected but cannot connect