<< return to Pixycam.com

Pixy2.1 not sending/not receive I²C data to/on Lego Ev3

I have read the following forum topic. [Solved]Failed to run ccc-test/RGB-test using Pixy2
However the problem described by the owner of the post is differ than mine.

I use my own cable to connect between EV3 and Pixy 2.1.

While running the CCC_test, the semi-circle sometime appear on the top of the screen and sometime not appearing at all.
When I try to toggle the LED input to true and re-download the program into EV3, the LED light not turning on too.

At PixyMon I do make sure my data output port is selected to Lego I²C. I also had check with all the possible I²C address using the the PixyMon setting.
Through further study I found that a pull-up resistor may require to pull up both SDA and SCL pin. So I also do use a 2k2 Ohm resistor pulling both pins to 5V. I also try all the above method on other EV3 bricks, and the semi circle mentioned above are mostly the same.
With all the above mentioned method. The result are still the same .

I cannot afford an oscilloscope at the moment for checking weather the I²C on the pixy cam side is still good.

Pixy’s LED should illuminate the color of the object that it’s detecting. If the LED is not on, Pixy isn’t detecting an object. This page will help improve the accuracy of your color signatures:


Pixy has the required pull-up resistors on the SDA and SCL. They are quite large – 47K if I remember.
The LEGO EV3 controller will not work with 4.7K pull-ups, so 2.2K is definitely not going to work.

Hope this helps.


Thanks for your reply @edge
Sorry for mentioning the wrong LED.
It isn’t the RGB LED not illuminate, but the white LEDs are what I mention.
When I toggle the Lamp on off setting as the picture below, the lamp does not turn on with the code. However when in computer pixymon app the lamp is turning on using the option in Action menu.
Screenshot 2022-03-04 at 9.05.04 AM

RGB LED working well, when plugging into computer, on picymon also show the signature object is detected.

I make a check for I²C address code on Arduino, the pixy2 is not sending out address from its I²C port no matter I²C or Lego I²C mode is selected in pixymon setting.

Hmm, I’m not sure what could be causing this. It sounds like you are having other communication issues besides the LED issue. Is that correct?