<< return to Pixycam.com

[Solved]Failed to run ccc-test/RGB-test using Pixy2

Hello there, I’m new to this pubic forum.
Recntly I’ve been trying to use Pixy2 on EV3 for future project, but after running through the quickstart step by step multiple times.( With different pixy2-ev3 cables, different ev3 bricks (all running firmware 1.09H), testing through MacOS and Win10 by EV3 mindstorm education 1.4.3)
Also, I’ve successfully imported the Pixy2 EV3 block, taught different Pixy2s an yellow object.
But when I ran the ccc-test, there were only a half circle appeared on the edge of the LCD screen and it would flickered randomly.
When I ran the RGB-test, the parameters of the three circles wouldn’t change a bit.
The pictures below show the circumstances I’ve been encountered.
Hope there will be a solution.

Let’s focus on the ccc-test for now.

When running the ccc-test, is the LED on Pixy2 illuminating, indicating that it is detecting the yellow object that you describe using? If the LED is not illuminating, Pixy2 is not detecting any objects.


Yes, the LED on Pixy2 do illuminating when detecting the yellow object.
I’ve also tried different object I taught, the LED would illuminated as well.
So did on different Pixy2.

Did you purchase Pixy2 LEGO which came with a LEGO v2 cable? Or are you using another cable?
Are you using thte Pixy2 LEGO firmware (which also came with Pixy2 LEGO), or are you using the general Pixy2 firmware? If so, what version of the firmware are you using?


So there is a different between Pixy2 and Pixy2 LEGO ?!
I’m using Pixy2 with Pixy2-LEGO cable shown in the picture below.
Also using general Pixy2 firmware.
Is there anyway to fix that ?

Thanks for your patience!
I’ve dowloaded the new firmware and now the ccc-test, the RGB-test can be ran successfully!

I’m glad you got it working.

I haven’t seen those cables with the red connectors. Can you please tell me where you purchased?